US12 Degraded Performance
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 04:42 UTC
Identified
The issue has been identified and a fix is being implemented. Next update at 10PM EST.
Posted Nov 21, 2024 - 20:54 UTC
Investigating
We are currently investigating this issue.
Posted Nov 21, 2024 - 20:53 UTC
This incident affected: US Region (US Platform 12).